一个由插件不兼容报错引发的升级php7.3的刚需

鸟叔最近登陆wordpress后台发现提示要升级到wordpress5.2.3,一直也没有升级,觉得没啥用。

今天一不小心将插件Ad Inserter升级到了最新版本2.5.5,随便打开一篇文章,居然打不开文章页面了,出现如下图的报错。

大概意思就是出现在Ad Inserter这个插件上,我暂停使用插件,页面恢复正常显示,问题就出现在这个插件上,我打开插件页面,有如下提示,意思就是说我的php版本和这个插件不兼容,要求升级php版本。

宝塔面板可视化界面升级php还是很简单的,具体方法如下:

首先登陆宝塔管理后台找到软件管理——运行环境,找到php7.3,为啥选php7.3呢,这个是wordpress给的建议,好处就是安全,网站运行速度快,搜索引擎给的权重高,真假不知道,鸟叔知道是很多插件一升级就不能用了,这个是刚需。

温馨提示在升级php之前,先备份网站和数据库。

找到php7.3安装好以后,登陆到网站php,切换到php7.3即可,鸟叔以前是最老版的php5.4.

切换之后就可以卸载老版本php了,重启网站服务器,php升级成功。

现在开启AD Inserter,文章页面正常显示,继续升级wordpress5.2.3。

到此为止被一个插件影响,更新了php和wordpress,升级php意味着对vps内存要求更高,这不是变相的逼我们升级vps吗?这年头挣点银子真不容易。

原创文章,转载请注明: 转载自鸟叔の窝

本文链接地址: 一个由插件不兼容报错引发的升级php7.3的刚需

一个由插件不兼容报错引发的升级php7.3的刚需》有10个想法

发表评论

电子邮件地址不会被公开。 必填项已用*标注